[财经]通信达公式指标大全 通达信漏网之鱼主图指标公式

浏览次数:收录时间:2020-09-03 03:18
【内容提要】通信达公式指标大全 通达信漏网之鱼主图指标公式,M1:MA(MA(L,3),3),COLORWHITE; M2:HHV(M1,60),COLORWHITE; M3:SQRT(M1*M2),COLORWHITE; M4:SQRT(M1*M3),COLORWH

  M1:MA(MA(L,3),3),COLORWHITE;

  M2:HHV(M1,60),COLORWHITE;

  M3:SQRT(M1*M2),COLORWHITE;

  M4:SQRT(M1*M3),COLORWHITE;

  M5:SQRT(M2*M3),COLORWHITE;

  ZDT:=(C-REF(C,1))/REF(C,1)*100;

  STICKLINE(ZDT>5,O,C,2,0),COLORYELLOW;

  STICKLINE(ZDT<-9.8,O,C,2,0),COLOR00FF00;

  涨停:=ZDT>5;

  不破价:=REF(L,BARSLAST(涨停));

  TJTS:=BARSTATUS=2;

  VAR1:=(C+L+H)/3;

  VAR2:=EMA(VAR1,6);

  VAR3:=EMA(VAR2,5);

  VAR4:=EMA(VAR3,12);

  VAR5:=EMA(VAR4,5);

  A10304:=REF(HIGH,3)=HHV(HIGH,2*3+1);

  B10304:=FILTER(A10304,3);

  C10304:=BACKSET(B10304,3+1);

  D10304:=FILTER(C10304,3);{高点}

  A20304:=REF(LOW,3)=LLV(LOW,2*3+1);

  B20304:=FILTER(A20304,3);

  C20304:=BACKSET(B20304,3+1);

  D20304:=FILTER(C20304,3);{低点}

  E10304:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;

  E20304:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}

  H10304:=(D10304 AND NOT(D20304 AND E10304>=E20304)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;

  L10304:=(D20304 AND NOT(D10304 AND E10304=E20304));

  X10304:=REF(BARSLAST(H10304),1)+1;

  F10304:=BACKSET(H10304 AND COUNT(L10304,X10304)>0,LLVBARS(IF(L10304,LOW,10000),X10304));

  G10304:=F10304>REF(F10304,1);

  I10304:=BACKSET(G10304,2);

  LD0304:=I10304>REF(I10304,1);{}

  L20304:=LD0304 OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;

  X20304:=REF(BARSLAST(L20304),1)+1;

  F20304:=BACKSET(L20304 AND COUNT(H10304,X20304)>0,HHVBARS(IF(H10304,HIGH,0),X20304));

  G20304:=F20304>REF(F20304,1);

  I20304:=BACKSET(G20304,2);

  HD0304:=I20304>REF(I20304,1);{过滤后高点}

  UU0304:=BACKSET(BARSTATUS=2,BARSLAST(LD0304)+1);

  VV0304:=UU0304>REF(UU0304,1);

  UU20304:=BACKSET(BARSTATUS=2,BARSLAST(HD0304)+1);

  VV20304:=UU20304>REF(UU20304,1);

  底:REF(L,BARSLAST(VV0304)),COLORRED,LINETHICK1;

  顶:REF(H,BARSLAST(VV20304)),COLORGREEN,LINETHICK1;

  STICKLINE(VV0304,顶,底,0,0),COLORGREEN,LINETHICK2;

  DRAWLINE(VV20304,H,VV0304,L,0),COLORGREEN,LINETHICK2;{斜}

  DRAWLINE(VV20304,H,VV0304,顶,0),COLORGREEN,LINETHICK2;

  STICKLINE(VV20304 ,顶,底,0,0),COLORRED,LINETHICK2;

  DRAWLINE(VV0304,L,VV20304,H,0),COLORRED,LINETHICK2;{斜}

  DRAWLINE(VV0304,L,VV20304,底,0),COLORRED,LINETHICK2;

  TY309:=C;

  HD309:=FILTER(BACKSET(FILTER(REF(TY309,10)=HHV(TY309,2*10+1),10),10+1),10);

  LD309:=FILTER(BACKSET(FILTER(REF(TY309,10)=LLV(TY309,2*10+1),10),10+1),10);

  A309:=REF(C,BARSLAST(HD309));

  B309:=REF(C,BARSLAST(LD309));

  T1309:=BARSLAST(HD309)

  T2309:=BARSLAST(HD309)>BARSLAST(LD309) AND NOT(LD309);

  波浪顶:IF(T1309,A309,A309),COLORCYAN,POINTDOT,LINETHICK2;

  波浪底:IF(T2309,B309,B309),COLORMAGENTA,POINTDOT,LINETHICK2;

  南方财富网微信号:南方财富网




回到顶部