通达信潜伏主图指标公式

浏览次数:收录时间:2020-09-02 05:44
【内容提要】通达信潜伏主图指标公式


通达信潜伏主图指标公式

 
 

加入日期:2018-1-9 22:21:08

 

 

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)
+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)
+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)
+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)
+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
马线:MA(牛线,6),COLORGREEN;
VAR0:=SMA(MAX(CLOSE-REF(C,1),0),12,1)/SMA(ABS(CLOSE-REF(C,1)),15,1)*100;
DRAWTEXT(CROSS(82,VAR0),HIGH,快卖),COLORWHITE;
S:=C-REF(C,1);
DX:=100*EMA(EMA(S,6),6)/EMA(EMA(ABS(S),6),6);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DA:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,4))/4;
DB:=(EMA(C,10)+EMA(C,20)+EMA(C,40)+EMA(C,80))/4;
DRAWTEXT(CROSS(DA-DB,0),L*0.95,★B),COLORRED;
JH:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;
DRAWTEXT(CROSS(84,JH),H*1.05,☆S),COLORGREEN;
YC:=REF(CLOSE,1);
止损价位:=(YC*1.0035*97+0.2)/99.65,COLORRED,LINETHICK0;
A:=HHV(HIGH,13)=HIGH AND HIGH>REF(HIGH,1);
A1:=FILTER(A,12);
B:=LLV(LOW,13)=LOW AND LOW<REF(LOW,1);
B1:=FILTER(B,12);
TS1:=BARSLAST(A1);
箱顶:=REF(HIGH,TS1) ,COLORFF00FF, LINETHICK0;
STICKLINE(1,箱顶,箱顶,7,0),COLORFF00FF;
TS2:=BARSLAST(B1);
箱底:=REF(LOW,TS2) ,COLORFFBB80, LINETHICK0;
STICKLINE(1,箱底,箱底,7,0),COLORFFBB80;
箱高:=100*(箱顶-箱底)/箱底,LINETHICK0;
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日阻力:=2*E-LOW,NODRAW;
明日支撑:=2*E-HIGH;
明日突破:=E+(HIGH-LOW);
明日反转:=E-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
DRAWTEXT_FIX(ISLASTBAR,0.6,0.1,0,明日阻力),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.7,0.1,0,明日阻力),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.2,0,明日支撑),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.7,0.2,0,明日支撑),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.3,0,明日突破),COLORRED;
DRAWNUMBER_FIX(ISLASTBAR,0.7,0.3,0,明日突破),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.4,0,明日反转),COLORRED;
DRAWNUMBER_FIX(ISLASTBAR,0.7,0.4,0,明日反转),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.5,0,今日阻力),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.7,0.5,0,今日阻力),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.6,0,今日支撑),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.7,0.6,0,今日支撑),COLOR0080FF;
AA:=MA(牛线,6);
MA3:=MA(C,3);
角度:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.14159>45 AND DYNAINFO(8)>0 ;
RSV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
KD金:=K<30 AND D<30 ;
ZBJ:=CROSS(MACD.DIF,MACD.DEA) ;
潜伏:=角度 AND CROSS(MA3,AA) AND KD金 OR ( ZBJ
AND REF(CROSS(K,D),1) AND MA3>AA) OR (CROSS(MA3,AA) AND CROSS(K,D));
STICKLINE(潜伏>0,L,H,1,0),COLORYELLOW;
DRAWTEXT(潜伏,H,↙潜伏),COLORYELLOW;




回到顶部